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Blender – tworzenie prostej animacji szkieletowej 

autorzy: Sławomir Samolej, Piotr Szczerba, Politechnika Rzeszowska, Rzeszów 2013. 

1. Ustalanie sposobu wyświetlania danych w obszarze roboczym 

1.1. Proszę uruchomić program Blender. 

1.2. Proszę najechać kursorem na krawędź pomiędzy „górnym” menu, a obszarem roboczym okna.  

Kursor myszy powinien mieć kształt: ↕. Proszę przytrzymać lewy przycisk myszy (LPM) i przeciągnąć krawędź w dół. Ekran 

programu powinien wyglądać jak na rysunku 1: 

 Rys. 1 
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1.3. Proszę wybrać panel/zakładkę „View & Controls” (zaznaczona na kolor żółty). 

1.4. Proszę wybrać przyciski zaznaczone czerwoną obwódką. 

1.5. W przycisku „Smooth View” wartość 0  zamienić na 500. 

1.6. Osoby dysponujące laptopami bez wydzielonej „bocznej” klawiatury numerycznej powinny wybrać panel/zakładkę „System & 

OpenGL” i wcisnąć przycisk „Emulate Numpad”. Wtedy funkcje „bocznej” klawiatury numerycznej zostaną przeniesione na klawisze 

z cyframi w górnej części klawiatury (por. rys. 2). 

 Rys. 2 

1.7. Proszę „zwinąć” panel ustawień. 
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1.8. Proszę wybrać w górnym menu opcję „File→ Save Default Settings”. Spowoduje to trwałe zapamiętanie ustalonego trybu pracy 

programu. 

Uwaga 1: Na niektórych komputerach laboratoryjnych nie będzie możliwie „zapamiętanie” ustawień. Wtedy przy każdym 

ponownym uruchamianiu projektu trzeba będzie opisane wyżej ustawienia ponownie „ustawić”. 

Uwaga 2: Opcja „File→ Load Factory Settings” przywraca domyślne ustawienia programu Blender. 

 

2. Podstawowa obsługa programu Blender  

2.1. Proszę kliknąć lewym przyciskiem myszy w obszar roboczy okna.  

2.2. Poruszanie przyciskiem „scroll” = przybliżanie/oddalanie sceny  

2.3. Przytrzymanie przycisku „scroll” + przesuwanie myszy  = przesuwanie sceny 

2.4. Przytrzymanie przycisku „scroll” + przytrzymanie klawisza „Shift” + przesuwanie myszy = swobodne obracanie sceny 

2.5. Klawisze 1, 3, 7 – odpowiednio: widok z przodu, widok z boku, widok z góry 

2.6. Klawisz 0 – widok z kamery (i odwrotnie) 

2.7. Klawisz 5 – zmiana rzutu prostopadłego na perspektywiczny (i odwrotnie) 

2.8. Klawisze 6, 8, 4, 2 – obracanie sceny 

2.9. Polecenie: Proszę wypróbować omówione operacje. 

 

3. Podstawowe modyfikacje obiektów na scenie  

3.1. Program Blender pracuje w dwu podstawowych trybach: trybie obiektu -„Object Mode” (komponowanie sceny z obiektów) oraz 

trybie edycji - „Edit Mode” (modyfikowanie wybranego obiektu). Zmiana pomiędzy tymi trybami odbywa się przez przycisk „Tab”. 

3.2. W trybie „Edit Mode” można zaznaczyć grupę wierzchołków siatki przez klikanie poszczególnych wierzchołów podczas 

przytrzymywania klawisza „Shift”. 

3.3. Zaznaczenie/odznaczenie wszystkich wierzchołków odbywa się przez przyciśniecie klawisza „A” 

3.4. Nieudane operacje można „cofnąć” kombinacją klawiszy „Ctrl + Z”    
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3.5. Zaznaczone grupy wierzchołków można poddać następującym transformacjom: 

- przesunięcie - należy wybrać klawisz „G”, następnie „X” lub „Y” lub „Z”, a następnie przesunąć mysz. Ostateczny efekt zatwierdza 

się przez klikniecie lewego przycisku myszy. Grupa wierzchołów będzie przesuwana odpowiednio wzdłuż osi X, Y, lub Z.  

- rotacja - należy wybrać klawisz „R”, następnie „X” lub „Y” lub „Z”, a następnie przesunąć mysz. Ostateczny efekt zatwierdza się 

przez klikniecie lewego przycisku myszy. Grupa wierzchołów będzie obracana odpowiednio wzdłuż osi X, Y, lub Z.  

- skalowanie – należy przycisnąć klawisz „S”, następnie „X” lub „Y” lub „Z”, a następnie przesunąć mysz. Ostateczny efekt 

zatwierdza się przez klikniecie lewego przycisku myszy. Grupa wierzchołów będzie skalowana odpowiednio wzdłuż osi X, Y, lub Z. 

- wyciąganie - należy przycisnąć klawisz „E”, następnie „X” lub „Y” lub „Z”, a następnie przesunąć mysz. Ostateczny efekt zatwierdza 

się przez klikniecie lewego przycisku myszy. Grupa wierzchołów zostanie „wyciągnięta” wzdłuż osi X, Y, lub Z.  

3.6. W trybie edycji można podzielić daną siatkę przez przecięcie ją pewną płaszczyzną podziału. Na przecięciu płaszczyzny i siatki 

zostaną utworzone nowe wierzchołki. W celu aktywowania podziału należy przycisnąć kombinację klawiszy „Ctrl+R”. Podczas 

przemieszczania kursora po siatce zostaną zaproponowane możliwe płaszczyzny podziału. Po pierwszym kliknięciu myszą jest 

możliwe przesunięcie płaszczyzny podziału. Po drugim kliknięciu następuje „zatwierdzenie” podziału.  

3.7. Polecenie: Proszę wypróbować omówione techniki pracy na grupach wierzchołków.  

 

4. Tworzenie siatki 

4.1. Proszę rozpocząć tworzyć nowy projekt („File→New (Erase All)”). Na niektórych komputerach w laboratorium trzeba ponownie 

ustawić sposób obsługi programu Blender jak w punktach 1.2 – 1.7. 

4.2. Proszę najechać na krawędź pomiędzy obszarem roboczym okna i menu (jak w punkcie 1.2). Proszę przycisnąć prawy przycisk 

myszy i wybrać z menu kontekstowego polecenie „Split Area”. W obszarze roboczym okna pojawi się pionowa kreska ustalająca 

podział obszaru roboczego na dwa podobszary. Kliknięcie lewym przyciskiem myszy zatwierdza podział. Rysunek 3 pokazuje ono 

programu Blender po takim podziale. 
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 Rys. 3 

4.3. W lewym „podoknie” należy wybrać widok z przodu ( 1 ) (por. rys. 3) 

4.4. W prawym „podoknie” należy wybrać widok z boku ( 3 )  (por. rys. 3) 

4.5. Po kliknięciu w lewe z „podokien” należy wybrać tryb edycji („Edit Mode”). 

4.6. Domyślą siatkę (sześcian) należy dwukrotnie wydłużyć wzdłuż osi „Z” (S,  Z, przesunięcie myszki, kliknięcie LPM). 

4.7. Domyślą siatkę (sześcian) należy dwukrotnie zwęzić wzdłuż osi „Y” (S,  Y, przesunięcie myszki, kliknięcie LPM). 

4.8. Siatkę po tych modyfikacjach pokazano na rysunku 4. 
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Rys. 4 
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4.9. W lewym „podoknie” należy dokonać przecięcia siatki płaszczyzną równoległą do płaszczyzny „ZY” (Ctrl + R). Siatkę po tej 

modyfikacji pokazano na rys. 5. 

Uwaga: Proszę dokonać podziału w sposób niesymetryczny. Prawa część siatki powinna być mniejsza od lewej (por. rys. 5).  

  Rys. 5 
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4.10. Proszę zaznaczyć wierzchołki siatki należące do lewej bocznej ściany siatki (por. rys. 6) 

 Rys. 6 

4.11. Proszę usunąć zaznaczone wierzchołki przyciskając klawisz „Del” i wybierając z menu kontekstowego opcję „Vertices” (por. rys.  

6). 
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4.12. Siatka po takiej modyfikacji wygląda jak na rysunku 7. 

Rys. 7 
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4.13. Proszę zaznaczyć wszystkie wierzchołki siatki ( A ). 

4.14. Proszę dla tego obiektu włączyć modyfikator – lustro (ang. Mirror). W tym celu: 

- proszę w panelu „Modifiers” wybrać przycisk „Add Modifier”, a następnie opcję Mirror (por. rys. 8). 

- proszę w panelu „Mirror” włączyć przycisk „Do Cliping”. Zapobiega to transferowi wierzchołów przez lustro (por. rys. 9). 

- gdyby panel „Modifiers” był niewidoczny, można przewinąć zawartość okna z panelami (przycisnąć „Scroll” i przesunąć mysz). 

Rys. 8. 
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Rys. 9 

4.15. W rezultacie w oknie roboczym będzie widać poprzednią siatkę i jej lustrzane odbicie. Zastosowanie lustrzanego odbicia pozwala 

na tworzenie symetrycznych siatek. 
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4.16. Proszę przesunąć siatkę do lustra (G, X , przesunięcie myszki, kliknięcie LPM) , aby odbicie i oryginał „zlały” się w 

prostopadłościan. Rezultat operacji jest widoczny na rys. 10. 

Rys. 10 
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4.17. Proszę dokonać przecięcia siatki (Ctrl + R) dwoma płaszczyznami. Jedną równoległą do płaszczyzny ZY i drugą równoległą do 

płaszczyzny XY w takich proporcjach, jak to pokazano na rys. 11. 

 Rys. 11 
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4.18.  Proszę zaznaczyć wskazany na rys. 12 wielokąt. 

Rys. 12 
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4.19. Proszę zaznaczony wielokąt dwukrotnie „wyciągnąć” ( E (Rgion), X, przesunięcie myszy, kliknięcie LPM), aby uzyskać siatkę, jak na 

rysunku 13. 

Rys. 13 

4.20. W podobny sposób proszę „wyciągnąć” z odpowiedniego wielokąta „nogi” (rezultat będzie widziany na następnych rysunkach). 
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4.21.  Proszę wskazać wielokąt, który można potraktować jako miejsce, w którym zaczyna się szyja (por. rys. 14).  

 Rys. 14 
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4.22. Poprzez kolejne transformacje wyciągania (szyja: E (Region), Z , przesunięcie myszy, kliknięcie LPM), wyciągania (1/3głowy: E 

(Region), Z , przesunięcie myszy, kliknięcie LPM) skalowania(S, X, przesunięcie myszy, kliknięcie LPM) można uzyskać 1/3 modelu 

głowy (por.  rys. 15). 

Rys. 15 

4.23.   Wykonując kolejne wyciągnięcie, wyciągnięcie i skalowanie należy samodzielnie dokończyć modelowanie głowy.  
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4.24. W rezultacie otrzymano przybliżoną siatkę postaci ludzkiej. 

4.25.  W celu wygładzenia siatki należy zaznaczyć wszystkie wierzchołki ( A ), a następnie poddać siatkę modyfikatorowi o nazwie 

„Subsurf”. Rezultat wygładzania można zaobserwować na rys. 16. 

Uwaga: W panelu modyfikatora „Subsurf” można ustalić poziom wygładzania na „Level 2” (por. rys. 16) 

 Rys. 16 
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4.26.  Dalsze modyfikacje siatki pozostawia się inwencji osoby realizującej ćwiczenie. 

4.27. Na zakończenie tworzenia siatki należy przejść do trybu pracy na obiektach („Object Mode”) (Tab), a następnie zatwierdzić 

działanie zastosowanych modyfikatorów przez wybranie przycisków „Apply” w odpowiednich panelach modyfikatorów (por. rys. 

17) 

Rys. 17 
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5. Tworzenie szkieletu 

5.1.   Korzystając PPM (prawego przycisku myszy) należy umieścić „kolorowy celownik” (por. rys. 18) „wewnątrz siatki” na wysokości 

krocza. Jest to miejsce w którym zostanie włączony do sceny następny element sceny – szkielet. 

5.2. Proszę wybrać klawisz „spacja” i z menu kontekstowego wybrać „Add → Armature” (dodaj szkielet). 

 Rys. 18 
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5.3. Pierwsza kość szkieletu zostaje wtedy „wstawiona” wewnątrz siatki. 

5.4. Jeśli ma być ona widoczna należy włączyć w panelu Armature przycisk X-Ray (por. rys. 19). 

 Rys. 19 

5.5. Na scenie są teraz 2 obiekty, które stworzyliśmy: siatka i pierwsza kość szkieletu. 

5.6. Proszę kliknąć LPM w kość, a następnie przejść to trybu edycji szkieletu (Tab).  

5.7. Stosując znaną metodę „wyciągania” (E, Z, przesunięcie myszy, kliknięcie LPM) należy z pierwszej kości „wyciągnąć” kręgosłup 

postaci. Rezultat tworzenia tej części szkieletu pokazano na rysunku 20.  
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Rys. 20 

5.8. Korzystając PPM (prawego przycisku myszy) należy umieścić „kolorowy celownik” (por. rys. 21) „wewnątrz siatki” w miejscu, gdzie 

powinna być zaczepiona kość ramienia. 

5.9. Należy przycisnąć klawisz „Spacja” i z menu kontekstowego wybrać opcję „Add → Bone”. 
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Rys. 21 

5.10. W rezultacie we wskazanym miejscu zostanie „wstawiona” nowa kość. 

5.11. Kość można „złapać” za „głowę” i „położyć” w ramieniu. 
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5.12. Następnie proszę o „wyciągnięcie” z kości ramienia jeszcze jednej kości, która będzie decydowała o ruchu przedramienia. 

Przykładowy rezultat wymienionych operacji pokazano na rysunku 22. 

Rys. 22 

5.13. Kości przedramienia i ramienia należy logicznie połączyć z kręgosłupem. W tym celu proszę najpierw zaznaczyć kość ramienia, a 

potem trzymając klawisz „Shift” zaznaczyć jedną z kości kręgosłupa (por. rys. 22). 
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5.14. Proszę przycisnąć kombinację klawiszy „Ctrl+P” i wybrać „Keep offset”. Logiczne połączenie  pomiędzy kośćmi zaznaczone jest 

przez przerywaną linię. 

5.15. Należy kliknąć kość ramienia i w panelu „Selected Bones” zmienić jej nazwę na „Reka1.L”.  

5.16. Należy kliknąć kość przedramienia i w panelu „Selected Bones” zmienić jej nazwę na „Reka2.L” (por. rys. 23). 

Rys. 23 
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5.17. Proszę zaznaczyć obie kości ręki (LPM + Shift). 

5.18. Proszę przycisnąć kombinację (Shift+D), która zduplikuje zaznaczone kości, a następnie przesunąć myszką w górę i w prawo, aby 

nowe kości znalazły się obok siatki (por. rys. 24).  

Rys. 24 
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5.19. Przy zaznaczonych zduplikowanych kościach proszę z „dolnego” menu wybrać opcję „Aramture → Flip Left & Right Names” (por. 

rys. 25) 

Rys. 25 

5.20. W rezultacie nazwy zduplikowanych kości zostaną zmienione na „Reka1.R”, oraz „Reka2.R” 
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5.21. Proszę, przy zaznaczonych zduplikowanych kościach, wybrać na Panelu „Armature” przycisk „X-Axis Mirror” 

5.22. Proszę, przy zaznaczonych zduplikowanych kościach, spróbować rozpocząć przesuwanie zaznaczonych kości (G) 

5.23.  W rezultacie kości prawej kończyny powinny automatycznie „odbić się” po drugiej stronie kręgosłupa  (por. rys. 26) 

Rys. 26 
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5.24. Proszę przejść do trybu obiektów („Object Mode”) (Tab) 

5.25. Proszę najpierw zaznaczyć siatkę, a następnie przytrzymując klawisz „Shift” zaznaczyć szkielet. 

5.26. Proszę wybrać kombinację klawiszy „Ctrl+P” a następnie wybrać z menu kontekstowego opcję „Make Parent To – Armature” . 

5.27. Z kolejnego menu kontekstowego proszę wybrać opcję „Create From Bone Heat”

Rys. 27 

5.28. W rezultacie szkielet zostaje logicznie połączony z siatką i może wpływać na jej kształt. 
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5.29. W trybie obiektów („Object Mode”) proszę wskazać na szkielet. 

5.30. Proszę przełączyć tryb pracy na „Pose Mode” (Proszę kliknąć we wskazane na rys 28 miejsce interfejsu i wybrać „Pose Mode”) 

5.31. Proszę wskazać jedną z kości (zostanie zaznaczona na niebiesko), a następnie wykonać na niej operację rotacji (R).  

5.32. Siatka powinna zniekształcać się pod wpływem modyfikacji położenia kości (por. rys. 28) 

Rys. 28 
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6. Tworzenie animacji 

6.1. Zakładamy, że wyjściową pozą jest ta, która powstała zaraz po połączeniu szkieletu z siatką.  

6.2. Proszę zawartość prawego podokna przełączyć na „Action Editor” (por. rys. 29) 

 Rys. 29 
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6.3. Model postaci jest modyfikowany w „Pose Mode” 

6.4. Proszę zaznaczyć wszystkie kości ( A ) 

6.5. Proszę przycisnąć klawisz „i” i wybrać z menu kontekstowego „LocRotScale”. 

6.6. Spowoduje to pojawienie się w oknie „Action Editor” spisu kości wraz z symbolicznie zanotowaną pierwszą klatką animacji (por.  

rys. 30). 

Rys. 30 
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6.7. Proszę w oknie „Action Editor” z zastosowaniem prawego przycisku myszy wskazać następną klatkę kluczową, którą zamierza się 

zdefiniować (por. rys. 31) 

6.8. W oknie z siatką proszę zmodyfikować ustawienie wybranych kości, a następnie ponownie wykonać zadnia z punktów 6.4-6.6. 

6.9. Wykonując cyklicznie polecenia od punktu 6.4 do 6.8 można zanotować ustaloną sekwencję ruchów (por. rys. 31). 

Rys. 31 
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6.10. Proszę uruchomić zapamiętaną animację przez przyciśnięcie kombinacji klawiszy „Alt+A”  

Uwaga: domyślna ilość wyświetlanych klatek animacji to 250, stąd krótsze animacje będą wyświetlane „co pewien czas” 

6.11. Tworzony projekt na każdym etapie można zapisać do pliku („File → Save/Save As”). 

6.12. Utworzony wcześniej projekt można wprowadzić do programu Blender („File → Open”) 

6.13. Powodzenia w realizacji własnych projektów 

           Autorzy 


